Major oil leak....then it doesn't at all ??

rickbert

New member
Joined
Nov 16, 2012
Messages
18
Reaction score
0
Points
0
Age
55
Location
Just east of KC Missouri
Week before Thanksgiving 2019 I take my 94 Suburban on a 40 mile round trip mostly high speed interstate.

I get home and a few hours later I see oil all over the garage floor.

I'm think well no big deal it's old so probably a bad oil pan seal, main seal, oil cooler lines etc but I couldn't tell exactly where it came from as it was splattered all over.

I checked the dipstick and it indicated a quart low....so I thought I'll clean it up on the bottom as best I can and add a quart then keep an eye on it to maybe see where it's leaking.

HOWEVER now 2 months have gone by....I've driven it in town and at high interstate speeds many times and it hasn't leaked a dropped WHATSOEVER.

How can it leak out an entire quart during a 40 mile trip then not leak ONE drop after that ? I added no additives just the quart of oil it leaked, didn't touch or tighten anything but now it's fine ?

WHAT THE HECK ??
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,598
Reaction score
10
Points
38
Are you saying when completely cold the engine oil dipstick still shows full?
Are you sure the leak was engine oil?
You have checked all other fluid levels, coolant, transmission, if 4WD transfer case, differential, brake master cylinder?
Prior to the leak how long had it been since the oil filter had been changed?
 

rickbert

New member
Joined
Nov 16, 2012
Messages
18
Reaction score
0
Points
0
Age
55
Location
Just east of KC Missouri
Yes....since that happened I check it every morning before I go anywhere and still reads full with no more leaks

Yes I'm sure the leak was engine oil because before I left the day of the leak I checked the level and it was full then when I got back it was a quart low with oil all over the floor then I added a quart and it was back up to full.

Master cylinder level where it should be....I installed new brake hoses all around with all new parts about 5 years ago and only about 10,000 miles since then...brakes work fine.

Last oil change (w/filter) was June 2019...however I've only put about 1000 miles on it since then.

Took the radiator cap off and it's full and the overflow tank was/is still at where it should be.

Checked the trans fluid and it's where it should be and the fluid is still bright pink.

100% positive it was engine oil.

Baffling eh ??
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,598
Reaction score
10
Points
38
Any chance the oil was already on the floor when you pulled in and some other member of the household spilled oil and didn't clean it up?
 

rickbert

New member
Joined
Nov 16, 2012
Messages
18
Reaction score
0
Points
0
Age
55
Location
Just east of KC Missouri
Ha ha ....

No....just the wife and I here and she was at work.

Even if that were remotely possible it wouldn't explain the oil all over the bottom of the engine and the loss of a quart.

As I stated above.....it's just baffling.
 
Last edited:
Top