Heater and ac not functioning properly

honeyman

New member
Joined
Jan 3, 2022
Messages
3
Reaction score
1
Points
1
Hello everyone, first time post. I have searched and cannot find anything like the problem I am having, any help will be greatly appreciated.



2007 HHR only used occasionally now, but recently when driving I turned on the heater and then the front defroster, as well as rear defroster all worked fine. Then I noticed it was getting very hot in the car. I could not turn the temp down and could not redirect the airflow to floor. AC will not come on the lights on the control switches for the climate control do not function now (they did prior to this time) all air flow is from defroster vent, Fan speed switch works fine. This is one owner vehicle we purchased new. Only work done concerning heater /ac was leaves in the fan cover that caused noise, this was several years ago and no problem since then. Anyone have any ideas???
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,315
Reaction score
57
Points
48
Either the blend door motor has failed or the climate control has failed since you have no lights. A shop would have to run tests to determine the cause.
 

honeyman

New member
Joined
Jan 3, 2022
Messages
3
Reaction score
1
Points
1
Thank you for your reply, I lean more to climate control since I can not adjust the temp either and no lights to indicate ac on or rear defrost on.
 

honeyman

New member
Joined
Jan 3, 2022
Messages
3
Reaction score
1
Points
1
I want to thank those of you who took time to help me. Here is what I found, I removed the kick panel on passenger side of console and the wire/fuses seems to be a little loose.

I pushed all the connectors together and the fuses went in a tiny bit more and all functions returned to the control panel. So at least for now everything is working, thank you again
 
Top