Garage door opener doesn’t work with engine running

Zorad1000

New member
Joined
Jan 1, 2019
Messages
8
Reaction score
0
Points
1
1999 Suburban. So it has taken me about a year to figure out that the problem with my garage door opener is actually a problem with my Suburban. What happens is , the door opener works fine as long as the engine isn’t running but when I start the engine it won’t close or open the door, then I can turn off the engine and it will work fine again. But wait there’s more...after driving for a while and coming home the remote will open the door just fine with the engine running.
I suspect there is some kind of interference coming from the alternator or the ignition system. I forgot to mention that the door opener is not a factory installed option on my vehicle , it is a hand held remote. Before getting this far I tried a new battery for the remote, I swapped remotes with my car and I bought a new remote for the Suburban and I got a new battery for that remote. Nothing solved the problem. Any help is greatly appreciated.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,683
Reaction score
15
Points
38
Have you tried moving the antenna on the garage door motor?
 

Zorad1000

New member
Joined
Jan 1, 2019
Messages
8
Reaction score
0
Points
1
Have you tried moving the antenna on the garage door motor?
No I don’t remember doing that. But before I discovered that I could turn off the engine to get it to work I would leave the engine running and get out of the truck and walk over to the door , stick my arm into the garage and I’d have to press the button several to get the door to close .
 

Zorad1000

New member
Joined
Jan 1, 2019
Messages
8
Reaction score
0
Points
1
No I don’t remember doing that. But before I discovered that I could turn off the engine to get it to work I would leave the engine running and get out of the truck and walk over to the door , stick my arm into the garage and I’d have to press the button several to get the door to close .
So I just looked at the antenna it is hanging as close to straight down as it can . Looks like I took the rear plastic cover off and straightened out the antenna at some point.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,683
Reaction score
15
Points
38
Try having it go to left or right to see if it gets better reception.
In my case I have Sears and found the remotes fail, I have a collection of them that either dont work or are sporadic, and LiftMaster makes a better replacement.
 

Zorad1000

New member
Joined
Jan 1, 2019
Messages
8
Reaction score
0
Points
1
Try having it go to left or right to see if it gets better reception.
In my case I have Sears and found the remotes fail, I have a collection of them that either dont work or are sporadic, and LiftMaster makes a better replacement.
Ok thanks for the help.
 
Top