Chevy Sonic 2012 ignition problem + check oil sensor light on

DanielKh

New member
Joined
Sep 28, 2020
Messages
2
Reaction score
0
Points
1
Hello. I own a 2012 chevy Sonic. Recently, these two weird issue have been going on and I’d appreciate any help from you guys.
So first of all, everytime I start my engine for the first time after leaving it parked for a few hours, the engine turns on, makes a rattling sound, and then turns off. The when I try to start it again it works fine but still feels like it’s trying hard to stay on while at idle. Then here’s the other issue...while I drive everything is okay until I have to stop in traffic or at a red light, the car vibrates a little bit and the check oil light comes on and off. (This only happens when the car is on but not moving) after I accelerate the oil check lights go off and everything goes back to normal. Can anyone help me with this? Has anyone experienced something similar or maybe has an idea of what this could be? I was thinking maybe this could be due to a bad oil pressure sensor because my oil level is good. But I’m not sure because I don’t know if a bad sensor would cause a weird vibration and makes the car turn off after already turning on the first time (as mentioned above) or it could be two different issues due to two different things. Any help is much appreciated! Thanks
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,742
Reaction score
20
Points
38
You need to have the actual oil pressure checked due to the rattling sound.
Are you using the correct viscosity oil?
 
Top