99 Suburban issues

NathanC

New member
Joined
Feb 22, 2021
Messages
5
Reaction score
0
Points
1
Having a few issues with my 99 K1500. When I bought it I drove 3 hours back home with zero issues. First issue I had after a few days of having it was the battery was draining while sitting. Battery has since been replaced and the issue still exists. Second issue is it cranks but doesn’t start. Cranks like a champ but doesn’t hit for some reason. I’m still learning about these beasts and would love some help. Thanks!
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,935
Reaction score
37
Points
48
After you replaced the battery did the security light come on solid when trying to start?
Did you check the charging system before replacing the battery?
 

NathanC

New member
Joined
Feb 22, 2021
Messages
5
Reaction score
0
Points
1
After you replaced the battery did the security light come on solid when trying to start?
Did you check the charging system before replacing the battery?
Didn’t notice the security light. Will check that ASAP. Alternator did get replaced. Pulling correct power when I checked it with a multimeter
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,935
Reaction score
37
Points
48
If you are sure the battery and alternator are good you need to use your multimeter to test for a parasitic drain.
 

Twin_Flyer

New member
Joined
Feb 24, 2021
Messages
6
Reaction score
0
Points
1
Did you check for spark? Do you hear the fuel pump for a few seconds when the key is first turned on?

Check for any blown fuses?
 

NathanC

New member
Joined
Feb 22, 2021
Messages
5
Reaction score
0
Points
1
Did you check for spark? Do you hear the fuel pump for a few seconds when the key is first turned on?

Check for any blown fuses?
Fuses are all good. Haven’t checked spark yet but changing plugs and wires next paycheck so I’ll check then. Did not notice fuel pump engaging, will be checking that soon as well
 
G

G-976737

Having a few issues with my 99 K1500. When I bought it I drove 3 hours back home with zero issues. First issue I had after a few days of having it was the battery was draining while sitting. Battery has since been replaced and the issue still exists. Second issue is it cranks but doesn’t start. Cranks like a champ but doesn’t hit for some reason. I’m still learning about these beasts and would love some help. Thanks!
Similar issue. Alternator was draining battery when vehicle off. Charge battery & unplug alternator, see if battery now holds charge.
 
Top