2011 equinox theft-deterrent

jerry1967

New member
Joined
Jan 21, 2016
Messages
9
Reaction score
0
Points
0
Age
70
I have one key that when I put it in the ignition the theft-deterrent light comes on and will not leave so the car will not start. when I put the other key in the car does start and the theft- doesn't come on.

Another odd point is if I take the second key out that did turn the car on and put the key that didn't start in the car will start but I have to put it in fast. If I wait the car will not start and theft-deterrent light comes on.

Now the fob works the only thing that doesn't work is the key to the first one.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,589
Reaction score
9
Points
38
Did you just buy this vehicle and the second key doesnt work or all of a sudden it stopped working. If you just bought this vehicle the non-working transmitter/key have to be programmed to work with the vehicle.
 

jerry1967

New member
Joined
Jan 21, 2016
Messages
9
Reaction score
0
Points
0
Age
70
I had this vehicle and bought new fobs for it because they were broken. After I changed the fobs one key works good and the other will not work. I get the lock symbol on the dashboard.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,589
Reaction score
9
Points
38
How did you program them to work with the vehicle without going to a dealer?
 

jerry1967

New member
Joined
Jan 21, 2016
Messages
9
Reaction score
0
Points
0
Age
70
One worked from the start the other one will not work. I keep getting the theft deterrent for the other.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,589
Reaction score
9
Points
38
Did you have to provide your VIN to the company that sold you the fobs?
 

jerry1967

New member
Joined
Jan 21, 2016
Messages
9
Reaction score
0
Points
0
Age
70
Did you have to provide your VIN to the company that sold you the fobs?
no, awful strange one works and the other one doesn't. Same replacement fob. The fob that will not start the car will work to unlock the doors and I can start the car with the remote outside the car but as soon as I put it in drive it stalls.

the other one works perfectly.
 

jerry1967

New member
Joined
Jan 21, 2016
Messages
9
Reaction score
0
Points
0
Age
70
makes no sense that either one would work
Why would you say that? I still have the insides of the FOB from the original. The only difference is the casing. Still the key and the guts of the original.
 
Last edited:

zora

Staff member
Joined
Apr 24, 2012
Messages
3,589
Reaction score
9
Points
38
lets start all over, you said you got new FOBS which means the board inside would be new. Now you are saying you switched the board from the original into the new case??
 

jerry1967

New member
Joined
Jan 21, 2016
Messages
9
Reaction score
0
Points
0
Age
70
Ok guess I don't know what I am talking about Sorry. By saying I got new Fobs I meant the shell, not the insides. I just took the insides out of the old and put it into the new. One worked one didn't.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,589
Reaction score
9
Points
38
did you install a fresh battery?
did the one that doesnt work, work in the old shell?
the circuit board may be bad.
 

jerry1967

New member
Joined
Jan 21, 2016
Messages
9
Reaction score
0
Points
0
Age
70
thanks for your help

I gave up and went to the dealer and bought a new key, I was surprised it was only $60.
 
Top