2002 chevy-suburban 5.3 4wd p0300 Problem Need help

kamelred408

New member
Joined
Jan 12, 2020
Messages
2
Reaction score
0
Points
0
Hello all i am new to this forum and am looking for some help.

2002 chevy-suburban 5.3 4wd p0300 Problem

Parts That we have replaced with new OEM.

All Spark Plugs
All Spark Plug Wires
All Ignition Coils
All Fuel Injectors
Fuel Filter


I had not done those and the car has 200k Miles so i figure its about time anyways .
I do not want to just buy parts and hope for a fix.

I have an Autel mkx808 car scanner and can do live data and several other things with it.



What i have found is the misfires are happening on BANK 1 only

Cylinders 1 , 3 ,5 and 7 Misfire
Cylinders 1 and 7 Misfire the most.

When i drive the car it has a major loss of power and the CEL flashs at me.

here is what i have tested so far.



Live Data shows

Car at operating temp and at idle
Bank 1 Heated o2 sensor 1 Moves up and Down from 100 mv - 900 mv like normal

Bank 2 Heated o2 sensor 1 Moves up and Down from 100 mv - 900 mv like normal

Bank 1 Heated o2 sensor 2 Moves up and Down from 100 mv - 900 mv THIS IS NOT Normal

Bank 2 Heated o2 sensor 2 Stays steady 750ish mv

I thought maybe the cats where bad so i did a temp test and it seems fine im going to do another temp test tonight to make sure ill edit in the exact temps later.

Could it be the bank 1 cats are bad and causing a misfire on bank 1?


My fuel trims stay around 0 and move to -10
Bank one fuel trim moves towards -10 more then bank 2





Fuel Psi
Checked after car sat all night 0 psi
checked when key is turn but engine is not running 58-60 psi then starts to drop
Checked when car is running stays stead at 60 psi

fuel injector psi ( i have this feature on my scanner)
All Injectors Shoots up to 67 psi then down to 44 psi ( they are all new)


now some times after the car sits i have to prime the fuel lines to start the car so i know the pressure is dropping.

I dont see how that would cause a misfire one bank 1 only tho.

A new fuel pressure regulator is my next item but may need a fuel pump?


im building a smoke tester and have not done a compression test yet.



what could this p0300 random misfire be. its driving me crazy and i need the truck for a family trip soon.

any and all help would be great thank you
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,693
Reaction score
15
Points
38
below are the normal items listed for this code
Faulty spark plugs or wires
Faulty coil (pack)
Faulty oxygen sensor(s)
Faulty fuel injector(s)
Burned exhaust valve
Faulty catalytic converter(s)
Stuck/blocked/leaking EGR valve / passages
Faulty camshaft position sensor
Defective computer
 

kamelred408

New member
Joined
Jan 12, 2020
Messages
2
Reaction score
0
Points
0
thanks im i made a list of parts to test and what not


Video inside cylinder
Test Grounds
Test battery
Swap ignition coil wire Sets from bank 1 to bank 2
Decarbon upper engine
Compression Test
Smoke Test
swap rear h02 sensors
maf and map sensor
cam and crank sensor
Egr valve
Test cat
 
Top