2000 Cav with 67k miles, running hot, overheat issue

Clem

New member
Joined
Nov 22, 2020
Messages
2
Reaction score
0
Points
1
I had the thermostat replaced, drove fine next day, then went past middle line on gauge when idling the day after that. (which is why I had them look at it before and they said the therm was bad). Took to different mechanic, they said they can't find anything wrong :(. Then when got home, the oil light came on and went off. I turned car off and :cry: . I literally have no money to keep taking it in. The car was in a garage with one owner, old lady, for all this time, why only 67K miles. Looks brand new, but I don't know what to do about it heating up. sigh. Any thoughts would be helpful.

I did look on you tube to replace engine coolant temp sensor. I can do that myself
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,800
Reaction score
24
Points
38
When cold is the coolant reservoir full?
If you look in the engine oil fill cap, do you see a creamy brown substance?
Do you get lots of white smoke from the exhaust?
When cold is the oil level at the full mark and does the oil look clear?
When the vehicle is running hot, is the radiator fan running?
Do the mechanics you go to have ASE certification?
 

Clem

New member
Joined
Nov 22, 2020
Messages
2
Reaction score
0
Points
1
When cold is the coolant reservoir full? It was about 2 cm below full line when cold
If you look in the engine oil fill cap, do you see a creamy brown substance? No
Do you get lots of white smoke from the exhaust? No
When cold is the oil level at the full mark and does the oil look clear? Yes
When the vehicle is running hot, is the radiator fan running? Yes, came on right around 200
Do the mechanics you go to have ASE certification? Yes, and I've been going there for 30 years, they do a good job on everything I've had done before

also, they did say that they bled the air out too. One thing I noticed was I have one fan in front of car; i turned on the ac blower and that fan didn't come on, but it did when it got to temp 200. I checked the ac fuse under the hood and it was good. So, isn't that supposed to be the ac fan too? from all the videos I've seen, that fan always comes on when they turn on the ac. hmmm
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,800
Reaction score
24
Points
38
The fan not coming on could be the problem.
What are the symptoms when it overheats, just the temperature reading?
The second fan doesn't run when it overheats?
If so you may want to mention that to the mechanic.
 
Top