1995 Lumina turn signal/hazard issue

thebull55

New member
Joined
Nov 25, 2018
Messages
4
Reaction score
0
Points
0
Age
53
Hello, new guy on the block.
I am working on my daughter's 1995 Lumina 4 door sedan 3.1L. She was driving and the alternator died so she stalled out and lost everything. I replaced the alternator and all seemed well except she now doesn't have turn signals or hazards. They don't light up or anything. I checked the fuses and they are good. I changed the flasher and nothing. I tried to check the power at the flasher plug and couldn't get anything there. The only thing else I see now is the turn signal switch?

Does that cover the turn signals and flashers? Also, am I missing anything else worth checking into?

I appreciate any advice or help. Thank you!
 

thebull55

New member
Joined
Nov 25, 2018
Messages
4
Reaction score
0
Points
0
Age
53
I did check both fuses and they are good. They were working before the alternator change.

I am thinking on trying the switch. It looks like the one switch covers both.
 

thebull55

New member
Joined
Nov 25, 2018
Messages
4
Reaction score
0
Points
0
Age
53
I ordered a switch to try that since I can't find anything else. Going to install this weekend. Odd thing...I was following the car last night and out of habit she flips on her turn signal. When she turned on the left turn signal, the left brake light dimmed like it would when it flashed. It just stayed dim. I had her try the right, same thing. If she hits the hazards both dim. I replaced the flasher and no help.

Does that lead to any thoughts?
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,590
Reaction score
9
Points
38
check the ground connections.
you are sure the correct bulbs are being used and they are installed correctly?
 

thebull55

New member
Joined
Nov 25, 2018
Messages
4
Reaction score
0
Points
0
Age
53
I installed the switch over the weekend and we have turn signals and flasher!! That was a bitch to change, but got it done.

Thanks for the input.
 
Top