1980 Z28 Speedo swap

jpmanetti

New member
Joined
Oct 6, 2018
Messages
6
Reaction score
0
Points
0
Age
59
I have a 1980 Z28 with an 85 MPH speedo. I just purchased a 130 MPH speedo and did the swap. It does not read correctly and it jumps all over the place while driving. Do I need to change the filter capacitor on the firewall with one for a 130 speedo? If so, where can I purchase one?
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,631
Reaction score
13
Points
38
Did you buy new or used?
Your speedometer doesnt use a cable?
Are you sure the capacitor is for the speedometer and not the tachometer?.
 

jpmanetti

New member
Joined
Oct 6, 2018
Messages
6
Reaction score
0
Points
0
Age
59
Yeah...I was pissed when I wrote the thread....it is cable driven. I wasn't thinking straight. The capacitor is for the tach. Yes, I bought it used with a broken needle. I replaced the needle from my 85 mph speedo. The guy I bought it from stated "it worked fine before I put it on the shelf"...yeah right. I don't know of any companies out there that repair them either.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
3,631
Reaction score
13
Points
38
before giving up on it try lubricating the cable with speedometer/tachometer lubricant. The lubricant should be added at the transmission end of the cable and you can put a very very small amount at the speedo end. You do not want the lubricant entering the speedometer head.
This video is for a Corvette so it may be similar to yours.
https://www.youtube.com/watch?v=gmG-KF0h9-E
 
Top