09 Colorado electrical gremlins

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
My turuck has 66k miles on it. I was gone for three years and someone stole the battery out of the truck. It sat without a battery for 16-18 months. When I got home last May I put a new battery in it , changed the oil and the truck started right up and was running great. Sometime in July the security light came on, and at times you could turn the ignition 6 to 12 times before the starter would kick in. A short time passed and service TPMS is lit up. I had new TPMS' installed and then it showed low tire, and still shows that. Then my check engine light came on and it showed the O2 Sensor was bad, so I replaced that.
My tuck has been to almost every shop within 50 miles of where I live and NOBODY can diagnose any type of problem, including the local Chevrolet Dealership. I'm hoping someone here has heard of, or had these same problems and can guide my to what to do to correct my problem. So far this is what has been done without fixing the problem. The electronic ignition was replaced to include the wiring harness that hooks to it. The lock cylinder(ignition switch) was replaced. The TPMS' were replaced three times with no changes. The ECM was flashed and I was told the ECM was bad. I purchased a NEW AC Delco ECM had it installed and flashed, the only change since they did this is the fan for the heat and AC does not work. It's warming up in south Georgia and I would like to fiux my truck and get some AC blowing soon.
Thanks for any help you might provide.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,099
Reaction score
43
Points
48
What codes are currently showing for the check engine light and TPMS system?
For the security issue are you sure they didnt replace the BCM?
 

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
The check engine light went out when I replaced the O2 sensor, it is showing LOW TIRE but reading corrct pressure. I bought the ECM and had it installed and flashed.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,099
Reaction score
43
Points
48
Need to have the TPMS scanned for codes.
Again why the ECM and not the BCM, did someone actually rule out the BCM as the cause of the security issue?
 

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
The shop said that the BCM needed to be reprogrammed, so they scheduled the appointment. When I dropped it off to be flashed they did what they said was required and found that the ECM was bad. So I purchased the ECM and they installed it and flashed it. The next morning when I started my truck the security light came on again, after driving for about ten minutes the fan in the dash quit and has not come back on since. The shop has been doing more research into what might be my next step to correct the issues. As for the TPMS, they have attempted to reset them and when they get done the vehicle horn does not beep twice as it is suppose to indicating that they are programmed correctly.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,099
Reaction score
43
Points
48
Does this shop have a Tech II or equivalent diagnostic equipment?
Does this shop have ASE certified technicians?
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,099
Reaction score
43
Points
48
So on the TPMS what code does it show or do they just constantly reset it without any diagnosis?
 

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
It show LOW TIRE and they have tried to reprogram it numerous times and it will not reprogram.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,099
Reaction score
43
Points
48
Did they consider the sensor that is triggering the message has to be replaced?
 

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
There have been three sets of TPMS' all OEM attempted and none will go through the complete reprogramming.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,099
Reaction score
43
Points
48
So they dont think at this point the BCM is at fault?
 

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
I as well as the shop cannot figure out what is wrong. That's why I came on the forum to see if anyone else has experienced the same issues and what they had to do to correct the problem.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,099
Reaction score
43
Points
48
I'm on 3 GM brand forums and have never come across the TPMS system problem you are experiencing . You state it currently says low pressure but which tire?
 

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
The monitors are reading correctly on all four tires, but the dispaly shows LOW TIRE. They also will not sound the horn twice after the last tire is reprogrammed.
 

zora

Staff member
Joined
Apr 24, 2012
Messages
4,099
Reaction score
43
Points
48
So your vehicle doesn't have a driver information center showing the pressure in all 4 tires making it easy to pinpoint which tire the system is mistakenly reading low?
The inability to program leads me back to the BCM.
 

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
No my truck does not have that option on it. The shop stated that the TPMS' are reading correctly though. Well anyways it's back in the shop for more attempts to correct the issues and I have every finger and toe crossed that they get it right this time. I will keep you informed on what they do and what the results are.
 

tim_james2

New member
Joined
May 12, 2021
Messages
10
Reaction score
0
Points
1
Well I finally got my truck back and have my fingers crossed. Here is what they did. Replaced the ECM and BCM, they had to flash the systemm three times before it would accept the signal. The replaced the TPMS' with two more complete sets before the LOW TIRE light finally went out. I was instructed to drive it and if anything lights back up to notify them immediately.
 
Top