chevy forums   chevy forums
Go Back   Chevy Forums > Chevy Forums - Trucks, SUVs and Crossovers > Chevy Equinox Forum

Chevy Equinox Forum Discussions regarding the Chevrolet Equinox



Chevy Forum: My 2007 chevy equinox traction control and stabiltrack light is on?
Reply
 
Thread Tools
  #1  
Old 11-21-2010, 02:02 PM
emilymassie emilymassie is offline
Junior Member
 
Join Date: Nov 2010
Posts: 1
Default My 2007 chevy equinox traction control and stabiltrack light is on?

It says to service. Is it safe to drive home 20 miles? And does anyone know how much it will cost to fix?
__________________
Powered by Yahoo! Answers
Reply With Quote
  #2  
Old 05-11-2011, 08:27 AM
Chuzz Chuzz is offline
Senior Member
 
Join Date: May 2011
Age: 57
Posts: 761
Default Re: My 2007 chevy equinox traction control and stabiltrack light is on?

Did you ever get this issue resolved? That happened to the one I just bought. Talking to a service manager at a local dealership, I was told that it's a communication link error in the electronics. He said it's a short in one wire. Mine is being fixed at this time under the warranty I got with it. I'll talk to the service department today when I pick it up and see if they can explain to me what was wrong with it and what the fix was. I'm not happy that I've had this vehicle five days now and haven't really gotten to drive it.
__________________
"It's only when you see a mosquito landing on your testicles that you realize that there is always a way to solve problems without using violence."
Reply With Quote
  #3  
Old 05-13-2011, 08:03 AM
Chuzz Chuzz is offline
Senior Member
 
Join Date: May 2011
Age: 57
Posts: 761
Default Re: My 2007 chevy equinox traction control and stabiltrack light is on?

Mine is fixed for now. The only thing the dude told me was that it had a broken wire. That's kind of vague, I know, but it's the best answer I could get out of him. I've got a 3 month, 3,000 mile warranty from them and I'm pretty sure that GM has to cover these up to 100,000 miles. Check you local dealer and ask them. I'm wondering since it seem to be a common problem on the 07 models, if maybe a TSB has been issued? If you call your dealer, ask them about that too.
__________________
"It's only when you see a mosquito landing on your testicles that you realize that there is always a way to solve problems without using violence."
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:06 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
chevyforum.org recognizes that "Chevy", "Chevrolet", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. chevyforum.org is not affiliated in any way with the General Motors Corporation, Chevy, Chevrolet or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2014 Madison Ross Media Group. All rights reserved. Content published on ChevyForum.org requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Chevy? Check out your options at the links below:

No special deals available at this time...